<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=0">
<meta property="fb:pages" content="1885510495065962">
<meta property="fb:app_id" content="1583832161789007" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<title>Giant’s 5% storewide discount for seniors 60 &amp; above extended to weekend of June 25 to 26  - Mothership.SG - News from Singapore, Asia and around the world</title>
<meta property="fb:pages" content="1885510495065962">
<meta property="og:title" content="Giant’s 5% storewide discount for seniors 60 &amp; above extended to weekend of June 25 to 26 " />
<meta property="og:description" content="The discount was previously only valid on weekdays." />
<meta property="og:url" content="https://mothership.sg/2022/06/giant-senior-citizens-discount/" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://static.mothership.sg/1/2022/06/image10-5.jpg" />

<meta property="fb:pages" content="592308557475467" />
<link rel="amphtml" href="https://mothership.sg/2022/06/giant-senior-citizens-discount//amp">
<meta name="title" content="Giant’s 5% storewide discount for seniors 60 &amp; above extended to weekend of June 25 to 26 ">
<meta name="description" content="The discount was previously only valid on weekdays.">
<link rel="icon" type="image/png" href="/assets/images/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/images/favicon-16x16.png" sizes="16x16">
<script type="text/javascript" src="/assets/js/home.js"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PLGD58H');</script>
 <link href="https://fonts.googleapis.com/css?family=Fira+Sans:700,700i|Libre+Franklin:400,400i,700,700i" rel="stylesheet">
<script src="https://static.vidy.com/embed.min.js"></script>
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '112356165937356', {
});
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=112356165937356&ev=PageView&noscript=1"
/></noscript>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-43110072-1', 'mothership.sg');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>



<script src="//assets.adobedtm.com/2926360f3839/716a789d2964/launch-e53716caf862.min.js"></script>

<script id="moatads" type="text/javscript" src="https://z.moatads.com/mediacorpheader458604908711/moatheader.js"></script>

<meta property="fb:pages" content="592308557475467" />
</head>
<body class="home cap-sponsored-content giant lifestyle-news hot-deals cap-siti-hawa senior-citizen-discount " data-post-id="758004">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PLGD58H"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="fb-root"></div>
<script async defer src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2"></script>
<div class="top-nav">
<a href="https://mothership.sg">
<img class="logo" src="/assets/images/icons/svg/mothership-logo-white.svg" />
</a>
<img class="hamburger ham appear" src="/assets/images/icons/svg/menu-hamburger-white.svg" />
<img class="hamburger cross" src="/assets/images/icons/svg/menu-cross-white.svg" />
</div>
<ul id="menu-new-main-menu" class="categories categories-custom">
<li id="menu-item-27915" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27915"><a href="https://mothership.sg/category/news/">News</a></li>
<li id="menu-item-451126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451126"><a href="https://www.mothership.sg/tag/covid-19">Covid-19</a></li>
<li id="menu-item-27913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27913"><a href="https://mothership.sg/category/lifestyle/" class="more-nav" id="more-nav-27913">Lifestyle</a>
<ul class="sub-menu">
<li id="menu-item-287416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287416"><a href="https://mothership.sg/category/lifestyle/lifestyle-news">Lifestyle News</a></li>
<li id="menu-item-287415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287415"><a href="https://mothership.sg/category/lifestyle/hot-deals/">Hot Deals</a></li>
<li id="menu-item-287420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287420"><a href="https://mothership.sg/category/lifestyle/trending/">Trending</a></li>
<li id="menu-item-287413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287413"><a href="https://mothership.sg/category/lifestyle/drama/">Drama</a></li>
<li id="menu-item-287419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287419"><a href="https://mothership.sg/category/lifestyle/things-to-eat/">Things To Eat</a></li>
<li id="menu-item-287418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287418"><a href="https://mothership.sg/category/lifestyle/things-to-do/">Things To Do</a></li>
<li id="menu-item-287417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287417"><a href="https://mothership.sg/category/lifestyle/stories-of-us/">Stories Of Us</a></li>
<li id="menu-item-287412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287412"><a href="https://mothership.sg/category/lifestyle/celebrity/">Celebrity</a></li>
<li id="menu-item-287414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414"><a href="https://mothership.sg/category/lifestyle/heartwarming/">Heartwarming</a></li>
<li id="menu-item-287415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287415"><a href="https://mothership.sg/category/lifestyle/travel/">Travel</a></li>
</ul>
</li>
<li id="menu-item-267017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267017"><a href="https://mothership.sg/videos">Videos</a></li>
<li id="menu-item-164942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942"><a href="https://mothership.sg/category/abroad/">Abroad</a></li>
<li id="menu-item-267009" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009"><a href="https://mothership.sg/tag/ms-weekend">Weekend</a></li>
<li id="menu-item-267009" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009"><a href="https://mothership.sg/category/environment">Environment</a></li>
<li id="menu-item-164943" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943"><a href="#" class="more-nav" id="more-nav-164943">+ More</a>
<ul class="sub-menu">
<li id="menu-item-267012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267012"><a href="https://mothership.sg/category/parliament/">Parliament</a></li>
<li id="menu-item-27916" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916"><a href="https://mothership.sg/category/perspectives/">Perspectives</a></li>
<li id="menu-item-165740" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740"><a href="https://mothership.sg/category/community/history/">History</a></li>
<li id="menu-item-27915" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://ge2020.mothership.sg">GE2020</a></li>
<li id="menu-item-271223" class="carrer-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-271223"><a href="https://mothership.sg/careers/">Careers</a></li>
</ul>
</li>
<a class="search search-main-menu mobile">
<li><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></li>
</a>
<a class="search search-main-menu desktop">
<li><img src="/assets/images/icons/svg/search-white.svg" /><span>Search</span></li>
</a>
<a class="search mobile">
<div class="category-item">
<p><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></p>
</div>
</a>
</ul>
<ul id="menu-new-main-menu-1" class="more-categories desktop-small-up">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27915"><a href="https://mothership.sg/category/news/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451126"><a href="https://www.mothership.sg/tag/covid-19">Covid-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27913"><a href="#" class="more-nav" id="more-nav-27913">Lifestyle</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414"><a href="https://mothership.sg/category/lifestyle/lifestyle-news">Lifestyle News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414"><a href="https://mothership.sg/category/lifestyle/hot-deals/">Hot Deals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287420"><a href="https://mothership.sg/category/lifestyle/trending/">Trending</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287413"><a href="https://mothership.sg/category/lifestyle/drama/">Drama</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287419"><a href="https://mothership.sg/category/lifestyle/things-to-eat/">Things To Eat</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287418"><a href="https://mothership.sg/category/lifestyle/things-to-do/">Things To Do</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287417"><a href="https://mothership.sg/category/lifestyle/stories-of-us/">Stories Of Us</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287412"><a href="https://mothership.sg/category/lifestyle/celebrity/">Celebrity</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414"><a href="https://mothership.sg/category/lifestyle/heartwarming/">Heartwarming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414"><a href="https://mothership.sg/category/lifestyle/travel/">Travel</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267017"><a href="https://mothership.sg/videos">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942"><a href="https://mothership.sg/category/abroad/">Abroad</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009"><a href="https://mothership.sg/tag/ms-weekend">Weekend</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009"><a href="https://mothership.sg/category/environment">Environment</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943"><a href="#" class="more-nav" id="more-nav-164943">+ More</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267012"><a href="https://mothership.sg/category/parliament/">Parliament</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916"><a href="https://mothership.sg/category/perspectives/">Perspectives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740"><a href="https://mothership.sg/category/community/history/">History</a></li>
<li id="menu-item-27915" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://ge2020.mothership.sg">GE2020</a></li>
<li class="carrer-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-271223"><a href="https://mothership.sg/careers/">Careers</a></li>
</ul>
</li>
<a class="search search-main-menu mobile">
<li><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></li>
</a>
<a class="search search-main-menu desktop">
<li><img src="/assets/images/icons/svg/search-white.svg" /><span>Search</span></li>
</a>
<a class="search mobile">
<div class="category-item">
<p><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></p>
</div>
</a>
</ul>
<div id="menu-new-main-menu-2" class="menu-items-mobile display-none">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27915">
<a href="https://mothership.sg/category/news/">
<div class="category-item">
<p>News</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451126">
<a href="https://www.mothership.sg/tag/covid-19">
<div class="category-item">
<p>Covid-19</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27913">
<a href="https://mothership.sg/category/lifestyle/" class="more-nav" id="more-nav-27913">
<div class="category-item">
<p>Lifestyle</p>
</div>
</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287416">
<a href="https://mothership.sg/category/lifestyle/lifestyle-news/">
<div class="category-item">
<p>Lifestyle News</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287415">
<a href="https://mothership.sg/category/lifestyle/hot-deals/">
<div class="category-item">
<p>Hot Deals</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287420">
 <a href="https://mothership.sg/category/lifestyle/trending/">
<div class="category-item">
<p>Trending</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287413">
<a href="https://mothership.sg/category/lifestyle/drama/">
<div class="category-item">
<p>Drama</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287419">
<a href="https://mothership.sg/category/lifestyle/things-to-eat/">
<div class="category-item">
<p>Things To Eat</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287418">
<a href="https://mothership.sg/category/lifestyle/things-to-do/">
<div class="category-item">
<p>Things To Do</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287417">
<a href="https://mothership.sg/category/lifestyle/stories-of-us/">
<div class="category-item">
<p>Stories Of Us</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287412">
<a href="https://mothership.sg/category/lifestyle/celebrity/">
<div class="category-item">
<p>Celebrity</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414">
<a href="https://mothership.sg/category/lifestyle/heartwarming/">
<div class="category-item">
<p>Heartwarming</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287415">
<a href="https://mothership.sg/category/lifestyle/travel/">
<div class="category-item">
<p>Travel</p>
</div>
</a>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267017">
<a href="https://mothership.sg/videos">
<div class="category-item">
<p>Videos</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942">
<a href="https://mothership.sg/category/abroad/">
<div class="category-item">
<p>Abroad</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009">
<a href="https://mothership.sg/tag/ms-weekend">
<div class="category-item">
<p>Weekend</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009">
<a href="https://mothership.sg/category/environment">
<div class="category-item">
<p>Environment</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943">
<a href="#" class="more-nav" id="more-nav-164943">
<div class="category-item">
<p>+ More</p>
</div>
</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267012">
<a href="https://mothership.sg/category/parliament/">
<div class="category-item">
<p>Parliament</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916">
<a href="https://mothership.sg/category/perspectives/">
<div class="category-item">
<p>Perspectives</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740">
<a href="https://mothership.sg/category/community/history/">
<div class="category-item">
<p>History</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27915">
<a href="https://ge2020.mothership.sg">
<div class="category-item">
<p>GE2020</p>
</div>
</a>
</li>
<li class="carrer-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-271223">
<a href="https://mothership.sg/careers/">
<div class="category-item">
<p>Careers</p>
</div>
</a>
</li>
</ul>
</li>
<a class="search search-main-menu mobile">
<li><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></li>
</a>
<a class="search search-main-menu desktop">
<li><img src="/assets/images/icons/svg/search-white.svg" /><span>Search</span></li>
</a>
<a class="search mobile">
<div class="category-item">
<p><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></p>
</div>
</a>
</div>
<div class="menu-categories-mobile">
<div class="menu-items-container">
<div id="menu-new-main-menu-3" class="menu-items">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27915">
<a href="https://mothership.sg/category/news/">
<div class="category-item">
<p>News</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451126">
<a href="https://www.mothership.sg/tag/covid-19">
<div class="category-item">
<p>Covid-19</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943">
<a href="#" class="more-nav" id="more-nav-27913">
<div class="category-item">
<p>Lifestyle</p>
</div>
</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287416">
<a href="https://mothership.sg/category/lifestyle/lifestyle-news/">
<div class="category-item">
<p>Lifestyle News</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287415">
<a href="https://mothership.sg/category/lifestyle/hot-deals/">
<div class="category-item">
<p>Hot Deals</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287420">
<a href="https://mothership.sg/category/lifestyle/trending/">
<div class="category-item">
<p>Trending</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287413">
<a href="https://mothership.sg/category/lifestyle/drama/">
<div class="category-item">
<p>Drama</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287419">
<a href="https://mothership.sg/category/lifestyle/things-to-eat/">
<div class="category-item">
<p>Things To Eat</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287418">
<a href="https://mothership.sg/category/lifestyle/things-to-do/">
<div class="category-item">
<p>Things To Do</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287417">
<a href="https://mothership.sg/category/lifestyle/stories-of-us/">
<div class="category-item">
<p>Stories Of Us</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287412">
<a href="https://mothership.sg/category/lifestyle/celebrity/">
<div class="category-item">
<p>Celebrity</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287414">
<a href="https://mothership.sg/category/lifestyle/heartwarming/">
<div class="category-item">
<p>Heartwarming</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287415">
<a href="https://mothership.sg/category/lifestyle/travel/">
<div class="category-item">
<p>Travel</p>
</div>
</a>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267017">
<a href="https://mothership.sg/videos">
<div class="category-item">
<p>Videos</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942">
<a href="https://mothership.sg/category/abroad/">
<div class="category-item">
<p>Abroad</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009">
<a href="https://mothership.sg/tag/ms-weekend">
<div class="category-item">
<p>Weekend</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267009">
<a href="https://mothership.sg/category/environment">
<div class="category-item">
<p>Environment</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943">
<a href="#" class="more-nav" id="more-nav-164943">
<div class="category-item">
<p>+ More</p>
</div>
</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267012">
<a href="https://mothership.sg/category/parliament/">
<div class="category-item">
<p>Parliament</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916">
<a href="https://mothership.sg/category/perspectives/">
<div class="category-item">
<p>Perspectives</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740">
<a href="https://mothership.sg/category/community/history/">
<div class="category-item">
<p>History</p>
</div>
</a>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27915">
<a href="https://ge2020.mothership.sg">
<div class="category-item">
<p>GE2020</p>
</div>
</a>
</li>
<li class="carrer-menu menu-item menu-item-type-post_type menu-item-object-page menu-item-271223">
<a href="https://mothership.sg/careers/">
<div class="category-item">
<p>Careers</p>
</div>
</a>
</li>
</ul>
</li>
<a class="search search-main-menu mobile">
<li><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></li>
</a>
<a class="search search-main-menu desktop">
<li><img src="/assets/images/icons/svg/search-white.svg" /><span>Search</span></li>
</a>
<a class="search mobile">
<div class="category-item">
<p><img src="/assets/images/icons/svg/search-red.svg" /><span>Search</span></p>
</div>
</a>
</div>
</div>
</div>
<div class="menu-more-categories-mobile">
<div class="menu-items-container">
<div class="menu-items">
<a href="#" class="back">
<div class="category-item">
<p><span>&#8592;</span> Back</p>
</div>
</a>
</div>
</div>
</div>
<div class="search-bar">
<form role="search" method="get" action="/search">
<input type="text" name="s" placeholder="Search" autocomplete="on">
<button type="submit" value="Go">Go</button>
</form>
</div>
<div class="content home">
<div id="gtm-analytics-cloudace" style="display:none;">
Siti Hawa |
Sponsored
<script type="text/javascript">
    window.onload = function(e){
      if (typeof window.ga === "function") {
            ga('send', {
              hitType: 'event',
              eventCategory: 'author_pageview',
              eventAction: 'author_pageview_viewed',
              eventLabel: 'Siti Hawa'
            });
            ga('send', {
              hitType: 'event',
              eventCategory: 'author_pageview',
              eventAction: 'author_pageview_viewed',
              eventLabel: 'Sponsored'
            });
      }
    }
  </script>
</div>
<div class="header">
<h1 style="margin-top:20px">Giant’s 5% storewide discount for seniors 60 & above extended to weekend of June 25 to 26 </h1>
<p class="subtitle">The discount was previously only valid on weekdays.</p>
<div class="publish-info">
<p>
<span class="non-date">
<a href="https://mothership.sg/author/sponsored-content">
</a>
<span class="pipe">|</span>
</span>
<span class="non-date">
<a href="https://mothership.sg/author/siti-hawa">
<span class="author-name">Siti Hawa</span>
</a>
<span class="pipe">|</span>
</span>
<span class="non-date">
<a href="/author/sponsored-content">
<span class="author-name" style="color: #999;">Sponsored</span>
</a>
<span class="pipe">|</span>
</span>
<span class="publish-date">
<img class="clock" src="/assets/images/icons/clock.png" />
June 23, 2022, 06:26 PM </span>
</p>
</div>
<div class="social-share ">
<a href="https://www.facebook.com/sharer/sharer.php?u=https://mothership.sg/2022/06/giant-senior-citizens-discount/" class="social-fb-share" target="_blank">
<span><img src="/assets/images/icons/svg/fb-icon.svg" /></span>
</a>
<a href="https://twitter.com/share?text=Giant’s 5% storewide discount for seniors 60 &amp; above extended to weekend of June 25 to 26 &url=https://mothership.sg/2022/06/giant-senior-citizens-discount/" class="social-tw-share" target="_blank">
<span>
<img src="/assets/images/icons/svg/tw-icon.svg" />
</span>
</a>
<a href="whatsapp://send?text=https://mothership.sg/2022/06/giant-senior-citizens-discount/" data-action="share/whatsapp/share" class="social-whats-share">
<span>
<img src="/assets/images/icons/svg/whats-icon.svg" />
</span>
</a>
</div>
</div>
<figure class="featured-image">
<img src="https://static.mothership.sg/1/2022/06/image10-5.jpg" />
</figure>
<div class="side-bar">
</div>
<div class="main-item" id="post-758004">
<div class="content-article-wrap">
<p><span style="font-weight: 400;">If you’re planning to shop for groceries or back-to-school supplies with the family this weekend, here’s some good news.</span> </p><p><span style="font-weight: 400;">Giant will be making its five per cent discount for senior citizens specially available on June 25 and 26.</span> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 1200px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image7-4.png" alt="" width="1200" height="1200" class="size-full wp-image-758012" /> Photo via Giant
</figcaption>
</figure>
</p><p><span style="font-weight: 400;">This is on top of Giant’s ongoing promotion where seniors aged 60 and above can get a five per cent storewide discount at all their physical outlets on weekdays from June 14 to July 1.</span> </p><div data-ad-visibility-desktop="true" data-ad-visibility-mobile="true" id='ad-gpt-out_of_page_small' class='advertisement__container' data-js-options='{&quot;networkCode&quot;:&quot;4654&quot;,&quot;adUnit1&quot;:&quot;mothership&quot;,&quot;adUnit2&quot;:&quot;article&quot;,&quot;adUnit3&quot;:&quot;na&quot;,&quot;adUnit4&quot;:&quot;na&quot;,&quot;adUnit5&quot;:&quot;out_of_page_small&quot;}'></div>
<p><span style="font-weight: 400;">Compared to Giant's regular Senior Citizen scheme which offers seniors a three per cent discount on weekdays, this is an extra two per cent more.</span> </p><p><h2><b>Maximise savings on groceries </b></h2> </p><p><span style="font-weight: 400;">You can also maximise your savings at Giant by choosing Giant brand items and products from its ‘Lower Prices That Last’ campaign.</span> </p><p><span style="font-weight: 400;">Under the Lower Prices That Last campaign, Giant has introduced long-term price reductions on </span><span style="font-weight: 400;">over 700 </span><span style="font-weight: 400;">everyday essentials across its stores islandwide.</span> </p><p><span style="font-weight: 400;">Here are some groceries you can save on:</span> </p><p><h3><b>Any three vegetables for S$2 </b></h3> </p><p><ul> </p><p> <li style="font-weight: 400;" aria-level="1"> </p><p><h4><a href="https://giant.sg/sio-peck-chye-5055953" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Sio peck chye</span></a> <span style="font-weight: 400;">and</span> <a href="https://giant.sg/round-spinach-5055955" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Round spinach</span></a></h4> </p><p></li> </p><p></ul> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 1000px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image5-5.jpg" alt="" width="1000" height="525" class="size-full wp-image-758009" /> Photo via Giant
</figcaption>
</figure>
</p><p><ul> </p><p> <li style="font-weight: 400;" aria-level="1"> </p><p><h4><a href="https://giant.sg/chye-sim-msia-5055974" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Chye Sim</span></a> <span style="font-weight: 400;">and</span> <a href="https://giant.sg/kang-kong-msia-5055966" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Kang kong</span></a></h4> </p><p></li> </p><p></ul> </p><p><img src="https://static.mothership.sg/1/2022/06/image8-9.jpg" alt="" width="1000" height="525" class="alignnone size-full wp-image-758013" /> </p><p><ul> </p><p> <li style="font-weight: 400;" aria-level="1"> </p><p><h4><a href="https://giant.sg/shuwa-soda-soft-s-c-5055954" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Sharp spinach</span></a> <span style="font-weight: 400;">and</span> <a href="https://giant.sg/red-spinach-msia-5055956" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Red spinach</span></a></h4> </p><p></li> </p><p></ul> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 1000px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image6-6.jpg" alt="" width="1000" height="525" class="size-full wp-image-758010" /> Photo via Giant
</figcaption>
</figure>
</p><p><ul> </p><p> <li style="font-weight: 400;" aria-level="1"><a href="https://giant.sg/ft-vannamei-prawn-40-50-5104647" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Frozen thawed vannamei prawn (S$5/500g)</span></a></li> </p><p></ul> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 794px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image2-5.png" alt="" width="794" height="799" class="size-full wp-image-758006" /> Photo via Giant
</figcaption>
</figure>
</p><p><ul> </p><p> <li style="font-weight: 400;" aria-level="1"><a href="https://giant.sg/meadows-fresh-full-cream-milk-1l-5086181" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Meadows fresh full cream milk (S$1.95)</span></a><span style="font-weight: 400;"> and </span><a href="https://giant.sg/white-bread-5058034" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Giant enriched white bread (S$1.40)</span></a></li> </p><p></ul> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 1000px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image1-7.jpg" alt="" width="1000" height="525" class="size-full wp-image-758005" /> Photo via Giant
</figcaption>
</figure>
</p><p><ul> </p><p> <li style="font-weight: 400;" aria-level="1"><a href="https://giant.sg/chicken-broth-5011335" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Swanson clear chicken broth (S$1)</span></a><span style="font-weight: 400;"> and </span><a href="https://giant.sg/giant-cream-cracker-400g-5094108" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Giant cream cracker (S$1.50)</span></a></li> </p><p></ul> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 1000px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image4-7.jpg" alt="" width="1000" height="525" class="size-full wp-image-758008" /> Photo via Giant
</figcaption>
</figure>
</p><p><h2><b>Fun for the whole family</b></h2> </p><p><span style="font-weight: 400;">What’s more, if you have young children or grandchildren, here’s even more reason to shop at Giant.</span> </p><p><span style="font-weight: 400;">Simply spend a minimum of S$100 to redeem a free Zoomoov ride (valid till June 26) at Giant Hypermarkets Tampines and IMM.</span> </p><p><figure id="attachment" aria-describedby="caption-attachment" style="width: 1080px" class="wp-caption aligncenter">
<figcaption id="caption-attachment-468423" class="wp-caption-text">
<img src="https://static.mothership.sg/1/2022/06/image3-4.png" alt="" width="1080" height="1920" class="size-full wp-image-758007" /> Photo via Giant
</figcaption>
</figure>
</p><p><span style="font-weight: 400;">View the full list of Giant outlets </span><a href="https://giant.sg/store-locator" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">here</span></a><span style="font-weight: 400;">.</span> </p><p><b><i> </p><p></i></b><b><i>This sponsored article by Giant made the writer want to bring the whole family to Giant.</i></b></p></p> </div>
<div class="divider max"></div>
<div class="social-share bottom">
<a href="https://www.facebook.com/sharer/sharer.php?u=https://mothership.sg/2022/06/giant-senior-citizens-discount/" class="social-fb-share" target="_blank">
<span><img src="/assets/images/icons/svg/fb-icon.svg" /></span>
</a>
<a href="https://twitter.com/share?text=Giant’s 5% storewide discount for seniors 60 &amp; above extended to weekend of June 25 to 26 &url=https://mothership.sg/2022/06/giant-senior-citizens-discount/" class="social-tw-share" target="_blank">
<span>
<img src="/assets/images/icons/svg/tw-icon.svg" />
</span>
</a>
<a href="whatsapp://send?text=https://mothership.sg/2022/06/giant-senior-citizens-discount/" data-action="share/whatsapp/share" class="social-whats-share">
<span>
<img src="/assets/images/icons/svg/whats-icon.svg" />
</span>
</a>
</div>
<p class="follow-ms">
If you like what you read, follow us on <a href="https://www.facebook.com/MothershipSG">Facebook</a>, <a href="https://instagram.com/mothershipsg">Instagram</a>, <a href="https://twitter.com/MothershipSG">Twitter</a> and <a href="https://t.me/mothershipsg">Telegram</a> to get the latest updates.</p> <div class="divider max"></div>
</div>
</div>
<div style="clear: both;"></div>
<div class="footer">
<div>
<p class="links">
<a href="https://mothership.sg/about-us" class="anchor-scroll">About</a>
<span class="pipe">|</span>
<a href="https://mothership.sg/about-us#sales" class="anchor-scroll">Advertise with us</a>
<span class="pipe">|</span>
<a href="https://mothership.sg/about-us#contact-us" class="anchor-scroll">Contact us</a>
<span class="pipe">|</span>
<a href="https://mothership.sg/careers" class="anchor-scroll">We Are Hiring</a>
<span class="pipe">|</span>
<a href="https://mothership.sg/privacy-policy/">Privacy policy</a>
</p>
<p class="footnote">Copyright © 2020 Mothership. All rights reserved.</p>
</div>
</div>
<div class="screen"></div>
<script>
    if (typeof _satellite != "undefined") {
        _satellite.pageBottom();
    }
</script> <script type="text/javascript" src="/assets/js/libs.js"></script>
<script type="text/javascript" src="/assets/js/iframe_parent.js"></script>
<script type="text/javascript" src="/assets/js/iframe_resizer.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/80832119/mediacorp_imu_feb2020', [[320, 50], [320, 100], [300, 600], [300, 250]], 'div-gpt-ad-1581049451631-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
</body>
</html>
