<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=0">
<meta property="fb:pages" content="1885510495065962">
<!-- <meta property="fb:pages" content="592308557475467" /> -->

        <meta property="og:description" content="Can try it once. Or again. "/>
    
<!--Favicons-->
<link rel="apple-touch-icon" sizes="180x180" href="https://mothership.sg/wp-content/themes/mothership_new2/img/apple-touch-icon.png">
<link rel="icon" type="image/png" href="https://mothership.sg/wp-content/themes/mothership_new2/img/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://mothership.sg/wp-content/themes/mothership_new2/img/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="https://mothership.sg/wp-content/themes/mothership_new2/img/manifest.json">
<link rel="mask-icon" href="https://mothership.sg/wp-content/themes/mothership_new2/img/safari-pinned-tab.svg" color="#ed4545">
<meta name="theme-color" content="#ffffff">


<title>McGriddles already available in S&#8217;pore ahead of June 7, 2018 &#8211; Mothership.SG</title>
<meta property="og:title" content="McGriddles already available in S&#8217;pore ahead of June 7, 2018"/>
<meta property="og:type" content="website"/>
<meta property="og:url" content="https://mothership.sg/2018/06/mcgriddles-singapore-back/"/>
<meta property="og:site_name" content="Mothership.sg"/>
<meta property="fb:app_id" content="453336618170676"/>
<meta property="og:image" content="https://mothership.sg/wp-content/uploads/2018/06/mcgriddles-back-featured.jpg"/>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mothership.SG &raquo; Feed" href="https://mothership.sg/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mothership.SG &raquo; Comments Feed" href="https://mothership.sg/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mothership.SG &raquo; McGriddles already available in S&#8217;pore ahead of June 7, 2018 Comments Feed" href="https://mothership.sg/2018/06/mcgriddles-singapore-back/feed/" />
		<script type="aa5eb7013a8598896e1cdc80-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mothership.sg\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ajax-load-more-css'  href='https://mothership.sg/wp-content/plugins/ajax-load-more/core/dist/css/ajax-load-more.min.css?ver=4.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='easy_author_image-css'  href='https://mothership.sg/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=4.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://mothership.sg/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_icons-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://mothership.sg/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpemfb-lightbox-css'  href='https://mothership.sg/wp-content/plugins/wp-embed-facebook/lib/lightbox2/css/lightbox.css?ver=4.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='mothership_new-style-css'  href='https://mothership.sg/wp-content/themes/mothership_new2/style.css?ver=4.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css'  href='https://mothership.sg/wp-content/themes/mothership_new2/css/slick.css?ver=4.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='slick-theme-css-css'  href='https://mothership.sg/wp-content/themes/mothership_new2/css/slick-theme.css?ver=4.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='main-css-css'  href='https://mothership.sg/wp-content/themes/mothership_new2/css/main-final.css?ver=201712061531' type='text/css' media='all' />
<link rel='stylesheet' id='override-css-css'  href='https://mothership.sg/wp-content/themes/mothership_new2/css/override.css?ver=1525757098' type='text/css' media='all' />
            <script type="aa5eb7013a8598896e1cdc80-">
                if (document.location.protocol != "https:") {
                    document.location = document.URL.replace(/^http:/i, "https:");
                }
            </script>
            <script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript">
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"100","ajax_url":"https:\/\/mothership.sg\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"239622","token":"16869a67e7"};
/* ]]> */
</script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/plugins/wordpress-popular-posts/public/js/tracking.js?ver=4.0.0'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/plugins/wp-embed-facebook/lib/lightbox2/js/lightbox.min.js?ver=4.9.3'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/plugins/wp-embed-facebook/lib/js/wpembedfb.min.js?ver=4.9.3'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript">
/* <![CDATA[ */
var WEF = {"local":"en_US","version":"v2.7","fb_id":""};
/* ]]> */
</script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/plugins/wp-embed-facebook/lib/js/fb.min.js?ver=4.9.3'></script>
<link rel='https://api.w.org/' href='https://mothership.sg/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mothership.sg/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mothership.sg/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Rosmah said to be carrying S$3,683 Versace bag when she went for questioning' href='https://mothership.sg/2018/06/rosmah-mansor-versace-bag/' />
<link rel='next' title='Trump-Kim Summit to be held at Sentosa&#8217;s Capella Hotel' href='https://mothership.sg/2018/06/trump-kim-summit-capella-hotel-sentosa/' />
<meta name="generator" content="WordPress 4.9.3" />
<link rel="canonical" href="https://mothership.sg/2018/06/mcgriddles-singapore-back/" />
<link rel='shortlink' href='https://mothership.sg/?p=239622' />
<link rel="alternate" type="application/json+oembed" href="https://mothership.sg/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmothership.sg%2F2018%2F06%2Fmcgriddles-singapore-back%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mothership.sg/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmothership.sg%2F2018%2F06%2Fmcgriddles-singapore-back%2F&#038;format=xml" />
<!-- Graceful Pull-Quotes plugin v2.6.1 -->
	<link rel="stylesheet" href="https://mothership.sg/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-core.css" type="text/css" />
	<link rel="stylesheet" href="https://mothership.sg/wp-content/plugins/graceful-pull-quotes/styles/Default.css" type="text/css" />
	<script type="aa5eb7013a8598896e1cdc80-text/javascript">
		var jspq_options = new Array("1", "1", "right", "1", "1", "blockquote", "pullquote", "pullquote pqRight");
	</script>
	<script type="aa5eb7013a8598896e1cdc80-text/javascript" src="https://mothership.sg/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes.js"></script>
<!-- end pull-quote additions -->
<link href="https://fonts.googleapis.com/css?family=Fira+Sans:700,700i|Libre+Franklin:400,400i,700,700i" rel="stylesheet">
<script type="aa5eb7013a8598896e1cdc80-text/javascript">
    var WP = {"baseFile":"https:\/\/mothership.sg\/wp-content\/themes\/mothership_new2","baseURL":"https:\/\/mothership.sg"}</script>

    <script type="aa5eb7013a8598896e1cdc80-text/javascript">
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') + 
    '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
    })();
    </script>
	
	
</script>


<!-- Start AdAsia-->
<script type="aa5eb7013a8598896e1cdc80-">

var unruly = window.unruly || {};

unruly.native = unruly.native || {};

unruly.native.siteId = 1080958;

unruly.native.onFallback = function adFallback() {

return 'script src="https://adnetwork.adasiaholdings.com/config.js?nwid=2060" type="text/javascript"></scr' + 'ipt>\n<scr' + 'ipt type="text/javascript">\n sas.setup({ domain: "https://adnetwork.adasiaholdings.com", async: true, renderMode: 0});\n // renderMode define when ads must be rendered:\n // - DEFAULT (0) : as soon as ad is ready\n // - READY (1) : render ads when document is ready\n // -ON_DEMAND (2) : user must callsas.callAds()\n</scr' + 'ipt>';
};

</script>

<script src="//video.unrulymedia.com/native/native-loader.js" type="aa5eb7013a8598896e1cdc80-"></script>
<!-- End AdAsia-->

<!-- Facebook Pixel Code -->
<script type="aa5eb7013a8598896e1cdc80-">
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '112356165937356', {

});
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=112356165937356&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->



<script type="aa5eb7013a8598896e1cdc80-">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-43110072-1', 'mothership.sg');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

    <script type="aa5eb7013a8598896e1cdc80-">
    function check_ga() {
      if (typeof ga === 'function') {
        return true;
      }else{
        return false;
      }
    }

    if(check_ga()){
                                                                ga('send','event','Author Stats','Mandy How','McGriddles already available in S&#8217;pore ahead of June 7, 2018');
            }
    </script>


<script type="aa5eb7013a8598896e1cdc80-text/javascript" src="https://ads.ayads.co/ajs.php?zid=19586"></script>';


</head>

<body data-rsssl=1 class="post-template-default single single-post postid-239622 single-format-standard group-blog">
<div id="fb-root"></div>
<script type="aa5eb7013a8598896e1cdc80-">
    window.fbAsyncInit = function() {
    FB.init({
        // appId      : '1376317702694777',
        appId      : '453336618170676',
        xfbml      : false,
        version    : 'v2.9'
    });

    
        FB.AppEvents.logPageView();
        
        	var share_total = 0;

            $.ajax({
              url: 'https://graph.facebook.com/?id=https://mothership.sg/2018/06/mcgriddles-singapore-back/',
              success: function(data){
                if (data.share) {
                    var count = data.share.share_count;
                    var old = $('.social-fb-share span').html();
                    if (isNaN(old) ){
                    	old = 0;
                    }

                    share_total = parseInt(old) + count;

                    console.log("https shares: " + count);

                    $.ajax({
		              url: 'https://graph.facebook.com/?id=ht'+'tp://mothership.sg/2018/06/mcgriddles-singapore-back/',
		              success: function(data2){
		                if (data2.share) {
		                    var count2 = data2.share.share_count;

		                    console.log("http shares: " + count2);

		                    count2 = count2 + share_total;

		                    if (count2 == 0) {
		                        count2 = 0;
		                    }

		                    if (count2 >= 1000 && count2<1000000) {
		                        count2 = count2/1000;
		                        count2 = count2.toFixed(1) + "K";
		                    }

		                    if (count >= 100000) {
		                        count2 = count2/1000000;
		                        count2 = count2.toFixed(1) + "M";
		                    }

		                    var fb_icon = '<img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/fb-icon.svg"/>';

		                    $('.social-fb-share span').html(fb_icon + count2);

		                }
		              }
		            });

                }
              }
            });




            };

    // (function(d, s, id){
    //     var js, fjs = d.getElementsByTagName(s)[0];
    //     if (d.getElementById(id)) {return;}
    //     js = d.createElement(s); js.id = id;
    //     js.src = "//connect.facebook.net/en_US/sdk.js";
    //     fjs.parentNode.insertBefore(js, fjs);
    // }(document, 'script', 'facebook-jssdk'));
    (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

$(function(){
    $('.social-fb-share').click(function() {
        FB.ui({
            method: 'share',
            href: 'https://mothership.sg/2018/06/mcgriddles-singapore-back/',
            }, function(response){});
    });
});
</script>
<div class="top-nav">
    <a href="https://mothership.sg">
        <img class="logo" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/mothership-logo-white.svg"/>
    </a>
    <img class="hamburger ham appear" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/menu-hamburger-white.svg"/>
    <img class="hamburger cross" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/menu-cross-white.svg"/>
</div>

<ul id="menu-new-main-menu" class="categories categories-custom"><li id="menu-item-27915" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27915"><a href="https://mothership.sg/category/news/">News</a></li>
<li id="menu-item-165740" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740"><a href="https://mothership.sg/category/community/history/">1819</a></li>
<li id="menu-item-27913" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27913"><a href="https://mothership.sg/category/lifestyle/">Lifestyle</a></li>
<li id="menu-item-164942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942"><a href="https://mothership.sg/category/abroad/">Abroad</a></li>
<li id="menu-item-164943" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943"><a href="#" class="more-nav">+ More</a>
<ul class="sub-menu">
	<li id="menu-item-27916" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916"><a href="https://mothership.sg/category/perspectives/">Perspectives</a></li>
	<li id="menu-item-27911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27911"><a href="https://mothership.sg/category/community/">Community</a></li>
	<li id="menu-item-102881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102881"><a href="https://mothership.sg/category/almost-famous/">Almost Famous</a></li>
	<li id="menu-item-142770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142770"><a href="https://mothership.sg/category/mps-in-the-house/">MPs in the House</a></li>
	<li id="menu-item-174941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-174941"><a href="https://mothership.sg/category/humour/">Offbeat</a></li>
	<li id="menu-item-57583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57583"><a href="https://mothership.sg/canornot">Polls</a></li>
</ul>
</li>
<li id="menu-item-27918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27918"><a href="https://mothership.sg/about-us/">About</a></li>
<li id="menu-item-221275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-221275"><a href="https://mothership.sg/careers/">Careers</a></li>
<a class="search search-main-menu mobile"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></li></a><a class="search search-main-menu desktop"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-white.svg"/><span>Search</span></li></a><a class="search mobile"><div class="category-item"><p><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></p></div></a></ul><ul id="menu-new-main-menu-1" class="more-categories desktop-small-up"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27915"><a href="https://mothership.sg/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740"><a href="https://mothership.sg/category/community/history/">1819</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27913"><a href="https://mothership.sg/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942"><a href="https://mothership.sg/category/abroad/">Abroad</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943"><a href="#" class="more-nav">+ More</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916"><a href="https://mothership.sg/category/perspectives/">Perspectives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27911"><a href="https://mothership.sg/category/community/">Community</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102881"><a href="https://mothership.sg/category/almost-famous/">Almost Famous</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142770"><a href="https://mothership.sg/category/mps-in-the-house/">MPs in the House</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-174941"><a href="https://mothership.sg/category/humour/">Offbeat</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57583"><a href="https://mothership.sg/canornot">Polls</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27918"><a href="https://mothership.sg/about-us/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-221275"><a href="https://mothership.sg/careers/">Careers</a></li>
<a class="search search-main-menu mobile"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></li></a><a class="search search-main-menu desktop"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-white.svg"/><span>Search</span></li></a><a class="search mobile"><div class="category-item"><p><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></p></div></a></ul><!-- <ul class="more-categories desktop-small-up"><a class="back"><li><span>&#8592;</span> Back</li></a></ul> -->
<div id="menu-new-main-menu-2" class="menu-items-mobile display-none"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27915"><a href="https://mothership.sg/category/news/"><div class="category-item"><p>News</p></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740"><a href="https://mothership.sg/category/community/history/"><div class="category-item"><p>1819</p></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27913"><a href="https://mothership.sg/category/lifestyle/"><div class="category-item"><p>Lifestyle</p></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942"><a href="https://mothership.sg/category/abroad/"><div class="category-item"><p>Abroad</p></div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943"><a href="#" class="more-nav"><div class="category-item"><p>+ More</p></div></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916"><a href="https://mothership.sg/category/perspectives/"><div class="category-item"><p>Perspectives</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27911"><a href="https://mothership.sg/category/community/"><div class="category-item"><p>Community</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102881"><a href="https://mothership.sg/category/almost-famous/"><div class="category-item"><p>Almost Famous</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142770"><a href="https://mothership.sg/category/mps-in-the-house/"><div class="category-item"><p>MPs in the House</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-174941"><a href="https://mothership.sg/category/humour/"><div class="category-item"><p>Offbeat</p></div></a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57583"><a href="https://mothership.sg/canornot"><div class="category-item"><p>Polls</p></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27918"><a href="https://mothership.sg/about-us/"><div class="category-item"><p>About</p></div></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-221275"><a href="https://mothership.sg/careers/"><div class="category-item"><p>Careers</p></div></a></li>
<a class="search search-main-menu mobile"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></li></a><a class="search search-main-menu desktop"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-white.svg"/><span>Search</span></li></a><a class="search mobile"><div class="category-item"><p><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></p></div></a></div><div class="menu-categories-mobile">
    <div class="menu-items-container">
        <div id="menu-new-main-menu-3" class="menu-items"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27915"><a href="https://mothership.sg/category/news/"><div class="category-item"><p>News</p></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-165740"><a href="https://mothership.sg/category/community/history/"><div class="category-item"><p>1819</p></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27913"><a href="https://mothership.sg/category/lifestyle/"><div class="category-item"><p>Lifestyle</p></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164942"><a href="https://mothership.sg/category/abroad/"><div class="category-item"><p>Abroad</p></div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-164943"><a href="#" class="more-nav"><div class="category-item"><p>+ More</p></div></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27916"><a href="https://mothership.sg/category/perspectives/"><div class="category-item"><p>Perspectives</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27911"><a href="https://mothership.sg/category/community/"><div class="category-item"><p>Community</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102881"><a href="https://mothership.sg/category/almost-famous/"><div class="category-item"><p>Almost Famous</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142770"><a href="https://mothership.sg/category/mps-in-the-house/"><div class="category-item"><p>MPs in the House</p></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-174941"><a href="https://mothership.sg/category/humour/"><div class="category-item"><p>Offbeat</p></div></a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57583"><a href="https://mothership.sg/canornot"><div class="category-item"><p>Polls</p></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27918"><a href="https://mothership.sg/about-us/"><div class="category-item"><p>About</p></div></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-221275"><a href="https://mothership.sg/careers/"><div class="category-item"><p>Careers</p></div></a></li>
<a class="search search-main-menu mobile"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></li></a><a class="search search-main-menu desktop"><li><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-white.svg"/><span>Search</span></li></a><a class="search mobile"><div class="category-item"><p><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/search-red.svg"/><span>Search</span></p></div></a></div>    </div>
</div>
<div class="menu-more-categories-mobile">
    <div class="menu-items-container">
        <div class="menu-items">
            <a href="#" class="back">
                <div class="category-item">
                    <p><span>&#8592;</span> Back</p>
                </div>
            </a>
        </div>
    </div>
</div>
<div class="search-bar">
    <form role="search" method="get" action="https://mothership.sg">
	<input type="text" name="s" placeholder="Search" autocomplete="on"><button type="submit" value="Go">Go</button>
</form></div>





<div class="content article-page">
<div class="article original" id="article-original">
		<div class="header">
    

    
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="aa5eb7013a8598896e1cdc80-"></script>
	<!-- Leaderboard -->
	<center>
	<ins class="adsbygoogle"
	 style="display:inline-block;width: 80%; height: 90px;margin: auto;"
	 data-ad-client="ca-pub-8151337340296717"
	 data-ad-slot="8357269786"></ins>
	 </center>
	<script type="aa5eb7013a8598896e1cdc80-">
	(adsbygoogle = window.adsbygoogle || []).push({});
	</script>
 


   
    <h1 style="margin-top:20px">McGriddles already available in S&#8217;pore ahead of June 7, 2018</h1>    <p class="subtitle">Can try it once. Or again. </p>        <div class="publish-info">
        <p>
                        <span class="non-date">By <a href="https://mothership.sg/author/mandy-how"><span class="author-name">Mandy How</span></a> <span class="pipe">|</span> </span><span class="publish-date"><img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/clock.svg" />5 hours</span>
        </p>
    </div><!-- /.publish-info -->
    <div class="social-share">
        <a href="#" class="social-fb-share">
            <span><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/fb-icon.svg"/></span>
        </a>
        <a href="https://twitter.com/share?text=McGriddles already available in S&#8217;pore ahead of June 7, 2018&url=https://mothership.sg/2018/06/mcgriddles-singapore-back/" class="social-tw-share" target="_blank"><span><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/tw-icon.svg"/></span></a><a href="whatsapp://send?text=https://mothership.sg/2018/06/mcgriddles-singapore-back/" data-action="share/whatsapp/share" class="social-whats-share"><span><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/whats-icon.svg"/></span></a>
    </div><!-- /.social-share -->
</div>
<figure class="featured-image">
    <img src="https://mothership.sg/wp-content/uploads/2018/06/mcgriddles-back-featured.jpg"/>
</figure>
<div class="side-bar">
		
			<div class="ad desktop-small-up">
			<div id='div-gpt-ad-1403852498237-0' style='width:300px; height:250px;'>
			<script type="aa5eb7013a8598896e1cdc80-text/javascript">
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403852498237-0'); });
			</script>
			</div> 
		</div>

        			<script type="aa5eb7013a8598896e1cdc80-text/javascript" async="true" src="//fo-api.omnitagjs.com/fo-api/ot.js?Placement=7a8ff54e48a4d73fb0dddc0d23fa5549"></script>
	<div class="divider"></div>
		<div class="most-popular events">
		<h2 class="section-title"><a href="https://mothership.sg/event">Events</a></h2>
        <div class="event-main-content">
<div class="ind-article top-story">
    <!-- <a href="https://mothership.sg/event/the-purple-symphony-2018/"> -->
            <a href="https://www.facebook.com/thepurplesymphony/" target="_blank">        <div class="container">
            <div class="featured-image" style="background-image: url('https://mothership.sg/wp-content/uploads/2018/05/32657532_10155806140693192_5935832372883750912_o.jpg')"></div>
            <div class="header">
                <h1>The Purple Symphony 2018</h1>
                <div class="publish-info" style="margin-top: 10px;display: block;">
                    <p>
                        <span class="publish-date">
                            <img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/clock.png" />
                            01 July 2018, -                        </span>
                    </p>
                </div>
                <div class="publish-info" style="margin-top: 10px;display: block;">
                    <p>
                        <span class="publish-date drop-pin">
                            <img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/drop-pin.png" />
                            University Cultural Centre                        </span>
                    </p>
                </div>
            </div>
        </div>
    </a>    <!-- </a> -->
    <div class="divider"></div>
</div>
</div>
    </div><!-- end .events -->
		<div class="most-popular">
		
<!-- WordPress Popular Posts Plugin [W] [weekly] [views] [custom] -->

<div id="wpp-3">
<h2 class="section-title">Upsurge</h2>            <script type="aa5eb7013a8598896e1cdc80-text/javascript">
                /* jQuery is available, so proceed */
                if ( window.jQuery ) {

                    jQuery(document).ready(function($){

                        var widget_container = $('#wpp-3');
                        widget_container.append('<p class="wpp-loader"><span>Loading...</span></p>');

                        $.get(
                            'https://mothership.sg/wp-admin/admin-ajax.php',
                            {
                                action: 'wpp_get_popular',
                                id: '3',
                                is_front: ''
                            }, function( response ){
                                widget_container.children("p.wpp-loader").remove();
                                widget_container.append(response);
                            }
                        );

                    });

                } /* jQuery is not defined */
                else {
                    if ( window.console && window.console.log ) {
                        window.console.log( 'WordPress Popular Posts: jQuery is not defined!' );
                    }
                }
            </script>
            
</div>
        <h2 class="section-title" style="display: none;">Upsurge</h2>
        <div class="flamin-hots" style="display: none;">
        	        </div>
    </div>
		
			</div>
<div class="main-item" id="post-239622" class="post-239622 post type-post status-publish format-standard has-post-thumbnail hentry category-lifestyle category-news category-food tag-fb tag-fast-food tag-food tag-mcdonalds tag-mcgriddles">
    
    <div class="content-article-wrap">
        <script async="async" data-cfasync="false" src="https://platform.twitter.com/widgets.js" charset="utf-8" type="text/javascript"></script>
<div id="fb-root"></div>
<p>The McDonald&#8217;s McGriddles were only supposed to be back in Singapore on June 7, for a limited time period:</p>
<blockquote class="wp-embedded-content" data-secret="QdVkbPmqWP"><p><a href="https://mothership.sg/2018/06/mcgriddles-singapore/">McGriddles available all day but back in S&#8217;pore for limited time only</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://mothership.sg/2018/06/mcgriddles-singapore/embed/#?secret=QdVkbPmqWP" data-secret="QdVkbPmqWP" width="600" height="338" title="&#8220;McGriddles available all day but back in S&#8217;pore for limited time only&#8221; &#8212; Mothership.SG" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
<div class="advertisement-custom-post ad">
                <center><span class="advertisement-custom-title" style="font-size: 14px;text-align: center;color: #999;">Advertisement</span></center>
                <div class="advertisement-custom-content" style="text-align:center;margin-bottom:30px;border-top: 1px solid #ccc;border-bottom: 1px solid #ccc;padding:12px 0 5px;"><script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="aa5eb7013a8598896e1cdc80-"></script>
<!-- 300 x 250 Med Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8151337340296717"
     data-ad-slot="4484566737"></ins>
<script type="aa5eb7013a8598896e1cdc80-">
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
            </div>
<p>However, social media posts have surfaced showing the anticipated breakfast item is already back in stores here two days earlier than announced:</p><div id="unruly-unit"></div> 
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">All-day breakfast McGriddles available from today, 5 June (soft-launch date) at all stores and McDelivery even though the official launch date is 7 June <a href="https://t.co/R5sGFRKmZH">pic.twitter.com/R5sGFRKmZH</a></p>
<p>&mdash; Xavier Lur (@xavierlur) <a href="https://twitter.com/xavierlur/status/1003834694692057089?ref_src=twsrc%5Etfw">June 5, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8" type="aa5eb7013a8598896e1cdc80-"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Welcome Back McGriddles! Already available today!!!!! <a href="https://t.co/mEwz82GLok">pic.twitter.com/mEwz82GLok</a></p>
<p>&mdash; Naz (@NazNazzeer) <a href="https://twitter.com/NazNazzeer/status/1003972684386992130?ref_src=twsrc%5Etfw">June 5, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8" type="aa5eb7013a8598896e1cdc80-"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">MY ONLY COMPLAINT IS THAT AFTER BREAKFAST TIME THERES NO HASH BROWNS 😩😩 other than that the McGriddles 15/10 <a href="https://t.co/dz4tMJgRJG">pic.twitter.com/dz4tMJgRJG</a></p>
<p>&mdash; Ray (@_heyyrayyy) <a href="https://twitter.com/_heyyrayyy/status/1003971567552946176?ref_src=twsrc%5Etfw">June 5, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8" type="aa5eb7013a8598896e1cdc80-"></script></p>
<div class="advertisement-custom-post ad">
                <center><span class="advertisement-custom-title" style="font-size: 14px;text-align: center;color: #999;">Advertisement</span></center>
                <div class="advertisement-custom-content" style="text-align:center;margin-bottom:30px;border-top: 1px solid #ccc;border-bottom: 1px solid #ccc;padding:12px 0 5px;"><script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="aa5eb7013a8598896e1cdc80-"></script>
<!-- 300 x 250 Med Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8151337340296717"
     data-ad-slot="4484566737"></ins>
<script type="aa5eb7013a8598896e1cdc80-">
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
            </div>
<p><img src="https://mothership.sg/wp-content/uploads/2018/06/mc-1.jpg" alt="" width="640" height="1136" class="aligncenter size-full wp-image-239623" srcset="https://mothership.sg/wp-content/uploads/2018/06/mc-1.jpg 640w, https://mothership.sg/wp-content/uploads/2018/06/mc-1-768x1363.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p>They are also available on GrabFood and the McDelivery site:</p>
<p><img src="https://mothership.sg/wp-content/uploads/2018/06/Screen-Shot-2018-06-05-at-10.12.41-pm.png" alt="" width="606" height="393" class="aligncenter wp-image-239626" srcset="https://mothership.sg/wp-content/uploads/2018/06/Screen-Shot-2018-06-05-at-10.12.41-pm.png 429w, https://mothership.sg/wp-content/uploads/2018/06/Screen-Shot-2018-06-05-at-10.12.41-pm-768x497.png 768w" sizes="(max-width: 606px) 100vw, 606px" /></p>
<p><img src="https://mothership.sg/wp-content/uploads/2018/06/grab-menu.png" alt="" width="595" height="1190" class="aligncenter wp-image-239624" srcset="https://mothership.sg/wp-content/uploads/2018/06/grab-menu.png 1440w, https://mothership.sg/wp-content/uploads/2018/06/grab-menu-768x1536.png 768w" sizes="(max-width: 595px) 100vw, 595px" /></p>
<!-- Related Stories -->
<div class="related-stories">
    <p class="caption">Story continues below</p>
    <div class="divider"></div>
    <h2 class="section-title">Some Articles That Could Use Traffic</h2>
                <div class="related-content">
            <a href="https://mothership.sg/2018/06/trump-kim-summit-capella-hotel-sentosa/" class="post-related-story" data-title="Trump-Kim Summit to be held at Sentosa&#8217;s Capella Hotel" data-id="239633">
                <div class="featured-image" style="background-image: url(https://mothership.sg/wp-content/uploads/bfi_thumb/Screen-Shot-2018-06-06-at-1.16.07-AM-36bna1bcmr7c1uq7wsq3gg.png)"></div>
                <div class="header">
                    <h1>Trump-Kim Summit to be held at Sentosa&#8217;s Capella Hotel</h1>
                                        <p class="subtitle">The White House thanks S'pore for its hospitality.</p>                </div>
            </a>
        </div>
        
                        <div class="related-content">
            <a href="https://mothership.sg/2018/06/rosmah-mansor-versace-bag/" class="post-related-story" data-title="Rosmah said to be carrying S$3,683 Versace bag when she went for questioning" data-id="239600">
                <div class="featured-image" style="background-image: url(https://mothership.sg/wp-content/uploads/bfi_thumb/rosmah-mansor-versace-bag-36bkwuld3o29xtdxzbclq8.jpg)"></div>
                <div class="header">
                    <h1>Rosmah said to be carrying S$3,683 Versace bag when she went for questioning</h1>
                                        <p class="subtitle">She was right-sizing for the occasion.</p>                </div>
            </a>
        </div>
        
                
        
            <div class="divider"></div>
</div><!-- /.related-stories -->


<p>And in the name of gluttony disguised as journalism, we ordered one for ourselves:</p>
<p><img src="https://mothership.sg/wp-content/uploads/2018/06/grab-order.png" alt="" width="565" height="1130" class="aligncenter wp-image-239625" srcset="https://mothership.sg/wp-content/uploads/2018/06/grab-order.png 1440w, https://mothership.sg/wp-content/uploads/2018/06/grab-order-768x1536.png 768w" sizes="(max-width: 565px) 100vw, 565px" /></p>
<p>It&#8217;s real, guys:</p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/BjpSllGnZm8/" data-instgrm-version="8" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:640px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:8px;">
<div style=" background:#F8F8F8; line-height:0; margin-top:40px; padding:50.0% 0; text-align:center; width:100%;">
<div style=" background:url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACwAAAAsCAMAAAApWqozAAAABGdBTUEAALGPC/xhBQAAAAFzUkdCAK7OHOkAAAAMUExURczMzPf399fX1+bm5mzY9AMAAADiSURBVDjLvZXbEsMgCES5/P8/t9FuRVCRmU73JWlzosgSIIZURCjo/ad+EQJJB4Hv8BFt+IDpQoCx1wjOSBFhh2XssxEIYn3ulI/6MNReE07UIWJEv8UEOWDS88LY97kqyTliJKKtuYBbruAyVh5wOHiXmpi5we58Ek028czwyuQdLKPG1Bkb4NnM+VeAnfHqn1k4+GPT6uGQcvu2h2OVuIf/gWUFyy8OWEpdyZSa3aVCqpVoVvzZZ2VTnn2wU8qzVjDDetO90GSy9mVLqtgYSy231MxrY6I2gGqjrTY0L8fxCxfCBbhWrsYYAAAAAElFTkSuQmCC); display:block; height:44px; margin:0 auto -44px; position:relative; top:-22px; width:44px;"></div>
</div>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/BjpSllGnZm8/" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Apparently #McGriddles are already in stores and available via McDelivery/GrabFood today. THEN STILL SAY LAUNCH 7 JUNE?!?! #IAmConfusion #NotComplaining</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/mothershipsg/" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Mothership.sg</a> (@mothershipsg) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2018-06-05T13:46:19+00:00">Jun 5, 2018 at 6:46am PDT</time></p>
</div>
</blockquote>
<p><script async defer src="//www.instagram.com/embed.js" type="aa5eb7013a8598896e1cdc80-"></script></p>
<p>Phew.</p>
<div class="advertisement-custom-post ad">
                <center><span class="advertisement-custom-title" style="font-size: 14px;text-align: center;color: #999;">Advertisement</span></center>
                <div class="advertisement-custom-content" style="text-align:center;margin-bottom:30px;border-top: 1px solid #ccc;border-bottom: 1px solid #ccc;padding:12px 0 5px;"><script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="aa5eb7013a8598896e1cdc80-"></script>
<!-- 300 x 250 Med Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8151337340296717"
     data-ad-slot="4484566737"></ins>
<script type="aa5eb7013a8598896e1cdc80-">
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
            </div>
<p><em>Top image from @<a href="https://twitter.com/xavierlur/status/1003834694692057089" target="_blank" rel="noopener">xavierlur</a> on Twitter and @<a href="https://www.instagram.com/mothershipsg/?hl=en" target="_blank" rel="noopener">mothership</a> on Instagram</em></p>
    </div>

    <!--Start AdAsia-->
            <div class="adasia_wrap">
            <div id="AdAsia"></div>
            <script type="aa5eb7013a8598896e1cdc80-text/javascript">
                sas.call("std", {
                    siteId:     124199, // 
                    pageId:     725903, // Page : SG_mothership.sg/mothership_outstream_mb
                    formatId:   44269,  // Format : Video-Read 1x1
                    target:     ''  // Targeting
                });
            </script>
            <noscript>
                <a href="https://adnetwork.adasiaholdings.com/ac?jump=1&nwid=2060&siteid=124199&pgname=mothership_outstream_mb&fmtid=44269&visit=m&tmstp=[timestamp]&out=nonrich" target="_blank">                
                    <img src="https://adnetwork.adasiaholdings.com/ac?out=nonrich&nwid=2060&siteid=124199&pgname=mothership_outstream_mb&fmtid=44269&visit=m&tmstp=[timestamp]" border="0" alt="" /></a>
            </noscript>
            
        </div>
        <!-- End Ads Asia -->

        <div class="divider max"></div>
    <div class="social-share bottom">
        <h3>Share this story:</h3>
        <a href="#" class="social-fb-share">
            <span><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/fb-icon.svg"/></span>
        </a>
        <a href="https://twitter.com/share?text=McGriddles already available in S&#8217;pore ahead of June 7, 2018&url=https://mothership.sg/2018/06/mcgriddles-singapore-back/" class="social-tw-share" target="_blank"><span><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/tw-icon.svg"/></span></a><a href="whatsapp://send?text=https://mothership.sg/2018/06/mcgriddles-singapore-back/" data-action="share/whatsapp/share" class="social-whats-share"><span><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/whats-icon.svg"/></span></a>
    </div>
        <p class="follow-ms">If you like what you read, follow us on <a href="https://www.facebook.com/MothershipSG">Facebook</a> and <a href="https://twitter.com/MothershipSG">Twitter</a> to get the latest updates.</p>
    <div class="divider max"></div>
    <div class="author-info">
                    <h2 class="section-title">About Mandy How</h2>
            <div class="author-image">
                <a href="https://mothership.sg/author/mandy-how">
                   <img src="https://mothership.sg/wp-content/uploads/2017/06/MH_Easy-Resize.com_.jpg">
                </a>
            </div><div class="author-blurb">
                <p>Mandy is a pantry rat. She eats everything in the pantry (except other people's food).</p>
            </div>
                    </div>
    <div class="divider max"></div>
    <div class="load-more fb">
        <a>Show Facebook comments</a>
    </div>
    <div class="fb-comments fb-comments-toggle" data-href="https://mothership.sg/2018/06/mcgriddles-singapore-back/" data-width="100%" data-numposts="5" data-colorscheme="light"></div>

    <div class="related-articles">
        <div class="divider max"></div>
        <h2 class="section-title">Story Playlists</h2>
        <div class="story-playlist-slick">
            <div class="story-playlist">
    <div class="scroll-button-container desktop-small-up">
        <button class="playlist-button" id="button-scroll-back">&#8592;</button>
    </div>
    <div class="scroll-button-container desktop-small-up">
        <button class="playlist-button" id="button-scroll-next">&#8594;</button>
    </div>
    <div class="playlist-1">
        <div class="playlist-2">
            <div>
                <div class="playlist-4 ie9up">
                    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=10,6,5,11" id="pl-weekly-recap">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 magenta">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/06/Screen-Shot-2018-06-06-at-1.16.07-AM.png)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/news.png" />
                        <p>
                            <span class="">Weekly Recap</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;">Recap of the week</p>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=6470" id="pl-social-media-fail">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 blue">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/05/scam-featured.jpg)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/thumbs-down.png" />
                        <p>
                            <span class="">Social Media Fail</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;">CMI</p>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=6474" id="pl-weird-af">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 orange">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/06/erotica-pervert.jpg)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/shrug.png" />
                        <p>
                            <span class="">Weird AF</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;"></p>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=6473" id="pl-flamin-hot-stories">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 red">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/06/donki-featured.jpg)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/fire.png" />
                        <p>
                            <span class="">Flamin' Hot Stories</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;"></p>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=6466" id="pl-s-poreans-anyhowly-driving">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 grey">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/06/Screen-Shot-2018-06-05-at-12.43.30-AM.png)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/car.png" />
                        <p>
                            <span class="">S’poreans Anyhowly Driving</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;"></p>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=6467" id="pl-where-to-eat">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 lightBlue">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/06/mcgriddles-back-featured.jpg)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/food.png" />
                        <p>
                            <span class="">Where To Eat?</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;"></p>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="playlist-5" url="https://mothership.sg/wp-admin/admin-ajax.php?action=story_playlist&id=6475" id="pl-s-pore-angst">
        <div class="playlist-6">
            <div class="playlist-7">
                <div class="playlist-9 lightGreen">
                    <div class="cover-image" style="background-image: url(https://mothership.sg/wp-content/uploads/2018/06/erotica-pervert.jpg)"></div>
                    <div class="colour ie9up"></div>
                    <div class="title">
                                                <img src="https://mothership.sg/wp-content/uploads/2017/06/angry.png" />
                        <p>
                            <span class="">S’pore Angst</span>
                            <span class="mobile"></span>
                        </p>
                        <p class="subtitle" style="display: none;"></p>
                    </div>
                </div>
            </div>
        </div>
    </div>
                </div>
            </div>
        </div>
    </div>
</div>

        </div>
        <h2 class="section-title" id="recommended-stories-header">Psst, here’s more interesting stuff:</h2>
        <div id="post-239633" class="ind-article">
	<a class="heres-more-link" data-title="Trump-Kim Summit to be held at Sentosa's Capella Hotel" data-id="239633" href="https://mothership.sg/2018/06/trump-kim-summit-capella-hotel-sentosa/">
		<div class="container">
			<div class="featured-image" style="background-image: url('https://mothership.sg/wp-content/uploads/2018/06/Screen-Shot-2018-06-06-at-1.16.07-AM.png')">
			</div>
			<div class="header">
                <h1>Trump-Kim Summit to be held at Sentosa's Capella Hotel</h1>
                				<p class="subtitle">The White House thanks S'pore for its hospitality.</p>                <div class="publish-info">
                    <p>
                                                <span class="publish-date"><img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/clock.png" />3 hours</span>
                    </p>
                </div>
            </div>
		</div>
	</a>
</div>
<div class="divider max"></div>

<div id="post-239600" class="ind-article">
	<a class="heres-more-link" data-title="Rosmah said to be carrying S$3,683 Versace bag when she went for questioning" data-id="239600" href="https://mothership.sg/2018/06/rosmah-mansor-versace-bag/">
		<div class="container">
			<div class="featured-image" style="background-image: url('https://mothership.sg/wp-content/uploads/2018/06/rosmah-mansor-versace-bag.jpg')">
			</div>
			<div class="header">
                <h1>Rosmah said to be carrying S$3,683 Versace bag when she went for questioning</h1>
                				<p class="subtitle">She was right-sizing for the occasion.</p>                <div class="publish-info">
                    <p>
                                                <span class="publish-date"><img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/clock.png" />9 hours</span>
                    </p>
                </div>
            </div>
		</div>
	</a>
</div>
<div class="divider max"></div>

<div id="post-239578" class="ind-article">
	<a class="heres-more-link" data-title="Don Don Donki opening 2nd outlet in 100AM mall, Tanjong Pagar on June 14, 2018, 10am" data-id="239578" href="https://mothership.sg/2018/06/don-don-donki-singapore-tanjong-pagar-100am-mall/">
		<div class="container">
			<div class="featured-image" style="background-image: url('https://mothership.sg/wp-content/uploads/2018/06/donki-featured.jpg')">
			</div>
			<div class="header">
                <h1>Don Don Donki opening 2nd outlet in 100AM mall, Tanjong Pagar on June 14, 2018, 10am</h1>
                				<p class="subtitle">The store's jingle is now stuck in your head. </p>                <div class="publish-info">
                    <p>
                                                <span class="publish-date"><img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/clock.png" />10 hours</span>
                    </p>
                </div>
            </div>
		</div>
	</a>
</div>
<div class="divider max"></div>

<div id="post-239267" class="ind-article">
	<a class="heres-more-link" data-title="Do you speak Westernised Chinese? You might already." data-id="239267" href="https://mothership.sg/2018/06/how-westernised-is-your-chinese/">
		<div class="container">
			<div class="featured-image" style="background-image: url('https://mothership.sg/wp-content/uploads/2018/06/5812224468_f7bdb211e6_o.jpg')">
			</div>
			<div class="header">
                <h1>Do you speak Westernised Chinese? You might already.</h1>
                				<p class="subtitle">Language changes.</p>                <div class="publish-info">
                    <p>
                                                <span class="publish-date"><img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/clock.png" />11 hours</span>
                    </p>
                </div>
            </div>
		</div>
	</a>
</div>
<div class="divider max"></div>

<div id="post-239562" class="ind-article">
	<a class="heres-more-link" data-title="Signal scrambled so World Cup 2018 on RTM TV 1 not shown in S'pore" data-id="239562" href="https://mothership.sg/2018/06/world-cup-2018-malaysia-signal-singapore/">
		<div class="container">
			<div class="featured-image" style="background-image: url('https://mothership.sg/wp-content/uploads/2018/06/free-world-cup-matches-in-singapore-not.jpg')">
			</div>
			<div class="header">
                <h1>Signal scrambled so World Cup 2018 on RTM TV 1 not shown in S'pore</h1>
                				<p class="subtitle">Whoever said sports doesn't pay is lying.</p>                <div class="publish-info">
                    <p>
                                                <span class="publish-date"><img class="clock" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/clock.png" />11 hours</span>
                    </p>
                </div>
            </div>
		</div>
	</a>
</div>
<div class="divider max"></div>

                            </div>
    
	</div>
<div class="divider"></div>
<div class="fb-share-slide appear">
    <a href="#" class="social-fb-share">
        <p><img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/svg/fb-icon.svg"/>Share on Facebook</p>
    </a>
</div></div><!-- end #article-original -->
</div><!-- end .content -->
<div style="clear: both;"></div>
<div class="footer">
    <div>
        <p class="links">
            <a href="https://mothership.sg/about-us#sales" class="anchor-scroll">Advertise with us</a> <span class="pipe">|</span> <a href="https://mothership.sg/about-us#contact-us" class="anchor-scroll">Contact us</a> <span class="pipe">|</span> <a href="https://mothership.sg/privacy-policy/">Privacy policy</a>
        </p>
        <p class="footnote">Copyright &copy; 2018 Mothership. All rights reserved. <br>
        <a href="http://www.vodien.com" target="_blank">Cloud hosting</a> by Vodien</a>. Web design by <a href="http://www.yushengteo.com" target="_blank">Yu Sheng</a> &amp; <a href="http://www.teoyusiang.com" target="_blank">Yu Siang</a>. <a href="http://www.ripplewerkz.com" target="_blank">Web development</a> by <a href="http://www.ripplewerkz.com" target="_blank">Ripplewerkz</a>.</p>
    </div>
</div>
<div class="playlist-feed">
    <div class="title playlist-yellow">
        <img class="icon" src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/playlist-icons/angry.png"/>
        <h2>Morning Commute</h2>
        <p class="subtitle">Interesting stories to discuss with your colleagues in office later</p>
        <p class="cross">
            <img src="https://mothership.sg/wp-content/themes/mothership_new2/img/icons/playlist-icons/close-icon.png" class="hidden-xs" />
            <span>Close</span></p>
    </div>
    <div class="items-container">
        <div class="items">
            
        </div>
    </div>
    <button class="playlist-button close">Close story playlist</button>
</div>
<div class="screen"></div>
<div class="playlist-screen"></div>
<div class="video-playlist-screen"></div>
<div class="video-playlist-video" style="background-color: #000;">
    <div class="video-item">
        
    </div>
    <!-- <iframe src="" width="560" height="100%" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe> -->
</div>

<script type="aa5eb7013a8598896e1cdc80-text/javascript">
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"479894638.3a81a9f.a529df36c8a640f8bc82902d7aa4d04d"};
/* ]]> */
</script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.9'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/themes/mothership_new2/js/navigation.js?ver=20151215'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/themes/mothership_new2/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/themes/mothership_new2/js/slick.js'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/themes/mothership_new2/js/index-final.js?ver=1525756301'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-content/themes/mothership_new2/js/mothership.js?ver=201710021609'></script>
<script type="aa5eb7013a8598896e1cdc80-text/javascript" src='https://mothership.sg/wp-includes/js/wp-embed.min.js?ver=4.9.3'></script>
<script type="text/javascript" data-cfasync="false" src='https://mothership.sg/wp-includes/js/wp-embed.min.js?ver=4.9.3'></script>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/4f936b58/cloudflare-static/rocket-loader.min.js" data-cf-nonce="aa5eb7013a8598896e1cdc80-" defer=""></script></body>
</html>

<!-- Dynamic page generated in 5.665 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2018-06-06 04:00:18 -->

<!-- super cache -->